rubyforen.de
http://forum.ruby-portal.de/

versuch gem install ruby-debug gescheitert
http://forum.ruby-portal.de/viewtopic.php?f=1&t=26535
Seite 1 von 1

Autor:  ustockie [ 15 Okt 2014, 15:26 ]
Betreff des Beitrags:  versuch gem install ruby-debug gescheitert

Hallo liebe leutz,

versuch verzweifelt mit gem install ruby-debug
ruby -v 1.8.7
rails -v 2.1.2
OS=Windows 7
Fehlermeldung:
make
makefile:130: warning: overriding commands for target `C:/Program'
makefile:124: warning: ignoring old commands for target `C:/Program'
makefile:130: warning: overriding commands for target `Files'
makefile:124: warning: ignoring old commands for target `Files'
make: *** No rule to make target `ruby.h', needed by `trace_nums.o'. Stop.

vielleicht hat einer von Euch eine Idee :-(

Autor:  BadBoy [ 15 Okt 2014, 16:35 ]
Betreff des Beitrags:  Re: versuch gem install ruby-debug gescheitert

  • Ruby 1.8.7 ist tot
  • Rails 2.y.z ist ebenfalls unmaintained
  • ruby-debug ist meineswissens nur für 1.8.z
  • Schaut ein wenig so aus, als kommt das Makefile nicht mit Leerzeichen in deinem Pfad zurecht.

Autor:  ustockie [ 15 Okt 2014, 21:06 ]
Betreff des Beitrags:  Re: versuch gem install ruby-debug gescheitert

Ist eigentlich viel aufwand den alten ruby code vers 1.8.7 rails 2.1.2 zu einer aktuellen Version migrieren?

Autor:  BadBoy [ 15 Okt 2014, 22:31 ]
Betreff des Beitrags:  Re: versuch gem install ruby-debug gescheitert

ustockie hat geschrieben:
Ist eigentlich viel aufwand den alten ruby code vers 1.8.7 rails 2.1.2 zu einer aktuellen Version migrieren?


1.8.7 → 1.9.z/2.y.z sollte relativ einfach sein.
Von Rails 2 auf Rails 3 oder 4 zu migrieren ist dafür mit sehr viel mehr Aufwand verbunden

Seite 1 von 1 Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/